ワークベンチ

コンテンツ:

  1. ワークベンチとドキュメントbasic
  2. ドキュメントを開くbasic
  3. イメージのマークアップbasic
  4. イメージの追加、削除basic
  5. テキストの作成、及び編集basic
  6. リンクの作成、表示basic
  7. GSXファイルの保存、読み込みbasic
  8. WebDAV 上のGSXファイルの保存、読み込みadvanced

basicは初心者も必ず読むべき項目を、advancedはアドバンスドな項目を表します。

09 この章に関連するSMART-GS0.9での変更は次のとおりです:

  1. 画像表示位置の選択可能化
  2. サーチ結果のハイライト表示の選択可能化
  3. 画像テキストと翻刻の行対応機能
  4. ワークベンチ型のエディタ
  5. テンポラリ画像マークアップ
  6. マウスカーソルのアイコン(バージョン0.8.1にも関連)

091 この章に関連するSMART-GS0.9.1 での変更は次のとおりです:

  1. Memopadの文字サイズの変更
  2. Bookmarkの色の変更

 

ワークベンチとドキュメント

ここではSMART-GS のワークベンチ、つまり、SMART-GSを利用するさい一番多く使うことになる主ウィンドウの使い方を説明します。 SMART-GSのワーベンチとは、起動したときに最初にでてくるウィンドウ、つまり、次のようなウィンドウのことです。

workbench winodw

 

ワークベンチには、この図のように左には Images, Notes という二つのタブつきペイン(ウィンドウの中の一部分のウィンドウ)が、右には史料の画像と、それに関連したテキスが表示される、上下二つのペインがあります。これらはデジタル画像であるか、テキストであるかの違いを除くと、すべて史料に関連する「文書」(ドキュメント, documents) です(注1.1)。以下、これらの4つのペインの役割を説明するために、まず、SMART-GS で扱える「ドキュメント」の種類と、SMART-GSにおけるそれらの名称について説明しましょう。

まず、最初に注意すべきことは、SMART-GSでは、研究に用いる史料の画像、画像に付随する文章、考えを述べた文章などをまとめてドキュメントと呼ぶということです。コンピュータ上で扱えるドキュメントには、大きく分けて、(1) 通常のテキスト、つまり、Wordのようなワープロやエディタで扱える「活字」ベースのものと、(2) 画像ドキュメント、つまり、史料をデジカメで取ったデジタル画像や、マイクロフィルムから作ったデジタル画像の、2種類があります。「透明テキスト付きPDFファイル」のようなハイブリッドなものが増えてきているものの、基本は、この二つに分類にできます。

SMART-GSは、この2種類のドキュメントを対応付けることが一筋縄ではいかないようなケース、つまり、史料のデジカメ画像をワードのファイルとしておこすことが困難な場合に、それを緩和するために作られたツールです。ですから、「透明テキスト付きPDFファイル」のように、この対応がOCRでほぼ自動的にできるような場合と異なり、この二つが意識的かつ明確に分離されています。SMART-GSは通常の印刷物とは違い一文字の範囲を同定することさえ困難な様な史料を研究するためのツールなのです(注1.1)。

この様な多様なドキュメントの内、文章が書かれた史料の画像をイメージ・ドキュメント Image Documentと呼び、SMART-GS上で文字コードで記述された文章をコード化ドキュメント Coded Documentと呼びます。 また短い別名として、Image Document を「イメージ」、Coded Document を「テキスト」とも呼びます。以下では、主にこの別名の方を使います。

以上は本質的な分類ですが、SMART-GSには、この他に、ドキュメントの利用方法による細かな分類があります。次にこれを説明しましょう。

テキストのうち、イメージに付随するものをIDAT(Image Document Attatched Text)と呼びます。IDAT は「アイダット」と発音します。ひとつのイメージに IDATは First IDAT、Second IDAT、Third IDAT の三つが存在します。これら三つがIDATの正式名称ですが、この章のIDATの名前変更で説明するように、その表示名はプロジェクトにあわせてユーザーが自由にかえることが可能です。

また、IDAT でないテキストを Note と呼びます。SMART-GS0.8では Note には User's Note, Explanatory Note の2種類があります。

以上を纏めると、次のようにドキュメントが分類されることになります:

これで漸くドキュメントの説明ができたので、話をワークベンチに戻しましょう。これまでの話が「難しすぎる」と思った人は、とりあえず、これまでの説明は忘れても構いません。使っている内に段々解ってくるはずですし、そうやってもSMART-GSは使用可能なのです。ということで、本題に戻ります。

ワークベンチには、4つのペインがあるといいましたが、ワークベンチの左側に表示されるタブ付きペイン Images のツリーをイメージ・ツリー(Images Tree)といい、タブつきペイン Notes のツリーをユーザズノート・ツリー(User's Notes Tree)といいます。ワークベンチの機能の説明を、次節からはじめますが、 まず、この二つの説明から始めましょう。

ドキュメントを開く

この節では、ドキュメントの開き方について解説します。直前に説明したように、ドキュメントにはイメージとユーザズ・ノートがあります。このそれぞれについて解説します。まずは、イメージからです。

イメージを開く(スプレッドを開く)

ワークベンチの左側に表示されるタブ付きペイン Images のツリーをイメージ・ツリー(Images Tree)ということはすでに説明しました。これは Windows などのOSのデータをファイルとフォルダ(ディレクトリ)と同じ、木の様な階層構造をしています。ただし、イメージ・ツリーはイメージ(Image Document)専用で、テキストなどは置けません。それが大きな違いですが、基本的な考え方はOSの場合と同じだと思って構いません。

SMART-GSで史料のデジタル画像を整理するときには、このイメージ・ツリーに置くことになります。デジタル画像をイメージ・ツリーに置く方法はイメージ・ツリーの追加・削除で説明しますが、 SMART-GSをインストールすると、すでにサンプルのイメージが幾つか入ってるので、最初は、それを使ってイメージの閲覧の仕方を覚えてください。以下、そういうサンプルを、みなさんがすでに手元に持っていることを前提に話を進めます。ただし、サンプルはリリースごとに少しずつ違いますので、以下の説明、特に画像は、手元にあるもの少々違っていても気にしないでください。

イメージツリーに置かれたイメージ(画像)を見たいときには、ファイル・アイコンを左ボタンでダブルクリックします。そうすると、次の図のようにイメージツリーの右側にイメージと、それに付随する三つのIDATが表示されます。このイメージと三つのIDATを合わせたものをスプレッド(Spread)と言います。この用語は SMART-GS特有のもので、よく使われるので必ず覚えておいてください。 イメージツリーのイメージ名をダブルクリックすると必ずIDATも一緒に開きますので(注2.1)、言葉を厳密に使えば、「イメージツリーのイメージ名をダブルクリックして開くには、イメージではなく、そのスプレッドである」ということになります。

また、図では、 S0_001 から S09_009までのイメージには [**]というマークが付いていますが、これは画像が検索可能になっていることの印です。これについてはこちらを参照してください。

開かれたスプレッド(イメージと三つのIDAT)

openingImage

こんな時には:イメージが表示されない

イメージ名をクリックしても期待したイメージが表示されないことがあります。これは幾つかのケースが考えられます。それを箇条書きにしましょう。

  1. 画像がブラックアウトする(真っ黒になる)。このケースで一番ありそうなのは、なんらかの理由でSMART-GSの描画能力が間に合わなかったケースです。多くの場合は、もう一度クリックすると表示されるでしょう。
  2. イメージ・ファイルが存在しないというエラーメッセージ・ダイアログが表示され、ワークベンチのイメージは画像のマークアップを除いて真っ白になり、左上に Image File Note Found という赤い字のエラーメッセージがでる。この場合は何等かの事故で画像が失われているのでエラーメッセージを参考にして画像ファイルを回復してください。
  3. 上のどちらにケースにも該当しない場合には、SMART-GS開発チームにご連絡ください。連絡の際はSMART-GS の開発サイト http://sourceforge.jp/projects/smart-gs/で、チケット機能を使ってください。チケットの使いかたは、http://sourceforge.jp/docs/ヘルプ/チケットを参考にしてください。

イメージ・ツリーのディレクトリあるいはフォルダ

イメージ・ツリーにはOSの場合の様なフォルダーがあります。これはフォルダ、あるいは、ディレクトリと呼ばれますが、イメージ・ツリーの場合はディレクトリということの方が多い傾向があります。この傾向に特に意味はありません。単に習慣の問題です。(^^)

イメージの順番の変更

イメージツリーでのイメージの並び順はファイルのアイコンをドラッグ&ドロップしたり、名前の順にソートしたりすることで順番を変更することが可能です。 ソートするときは、ソートしたい範囲をマウスで選択し右クリックメニューの Sort Selected Items By Name を選びます。コントロールキーを押しながら選択すると、現在選択されているものへの追加が、一つ選択した後で、シフトキーを押しながら別のものを選択すると、最初に選択したものと2番目に選択したものの間のすべてのものが選択することができます。

イメージのドラッグが可能なのは、同じフォルダの内部だけです。つまり、ドラッグして、他のフォルダに持って行くことはできないようになっています。また、名前を変更することさえできません。この制限には意図があるのですが、それはイメージとフォルダの追加と削除で説明します。

以上のことはイメージだけでなく、イメージを入れているディレクトリ(イメージツリーでは、OSのフォルダにあたるものとディレクトリという)に対しても適用されます。つまり、フォルダとイメージを選んでソートすると、イメージかフォルダーかは関係なく名前の順番に並びます。

注2.1. 開いていないように見えたら、右側のペイン(区画)の下のペインが狭く表示されて隠れている可能性がありますので、マウスで境界線の位置を変えてみてください)、

行の表示

画像であるイメージドキュメントに行を指定することが可能です。

行が指定してある場合には上の図のツールバーの赤矢印で示されたアイコンをクリックすると、次の様に行が行番号つきで表示されます。もう一度クリックすると行番号が消え、さらにもう一度クリックすると、今度は行を示す線分が全部消え、代わりに行番号だけが表示されます。さらにもう一度クリックすると行表示が終ります。

イメージの行は、他の人と画像について議論する時に役立ちます。たとえば、上の図には4個のレクトアングルがありますが、これを「0行目のレクトアングル」「6行目のレクトアングル」などと呼んで参照することができますので、他の研究者や学生と情報をやりとりする際に使えます。特に講義などでのプロジェクタを使ったプリゼンテーションの際に特定の行を指示するために便利です。そういう場合はプリゼンテーションを行なう人はレーザーポインタやマウスカーソルで場所を示すことができますが、聴衆はそうは行かないので、たとえばある部分について質問やコメントがあるときには、一々レーザポインタを質問者に渡して、どの部分についての質問か示してもらう必要があります。しかし、質問があった際に行番号を表示し、質問者に質問の該当箇所を行番号で言ってもらうと、行の中の位置は、ほぼ位置が特定できるので、容易に質問者・提示者・他の参加者の間で、イメージ上の該当箇所の共有ができます。

この様に便利な行と行番号ですが、これを指定することは、上の図のような複雑な行の構造を持つ文書ではそれほど簡単ではありません。この例の行指定は、 SegfoMaker改 というツールで行ないましたが、画面の左0-7番目までの行は、半自動的にそのツールが行なったものの、右側は人間(アルバイト学生)が一行一行指定して作ったものです。これは38-51行のあたりがで分かるように、後で行間に書き足しがされているので、それらも行として指定する必要があるが、それらをコンピュータに自動的に行なわせるのは困難だからです。

行の指定はOCRでの行切り出しにならって行切り出しと呼ばれます。これについての詳しい情報はイメージサーチ/テキストサーチの章の行・行切り出し・DSCファイルを参照してください。

09 行対応機能

SMART-GS 0.9 で導入された新しい機能の一つとして、行対応があります。これはイメージドキュメント(Image Document)の行と、その翻刻のテキスト(Coded Document)の行との対応を取る機能です。 この機能を使うには、
  1. イメージドキュメントに行が指定してある。
  2. First IDAT の各行の先頭に行番号が$1$, $2$,...,$14$ のような形式で指定してある。
という2条件が満たされている必要があります。

この二つの条件が満たされているとき、この動画 (YouTube版)のように、イメージドキュメントの行をダブルクリックすると First IDAT の該当行が検索されてハイライト表示され、 逆に、First IDAT のある行番号をダブルクリックすると、対応するイメージドキュメントの行と同じ形のテンポラリなポリゴンが作られ、それが選択されてハイライト表示されます。 配布されている SMART-GS0.9のサンプルgsxファイルでは、上記動画で使った田辺元史料のイメージドキュメントと、その翻刻である First IDAT の双方に行と行番号が指定してあるので、 動画を参考にして試してみてください。この機能は翻刻を進める際に、オリジナルの電子画像と、その翻刻の間の関係を維持するために大変便利です。

行番号をユーザが入れないといけないのは一見不便ですが、これはサンプル史料のように、複雑な書き込みがなされている場合は、 翻刻の行を First IDAT の勝手な場所におけるので便利です。定型のノートや日記に書かれた文書の研究、たとえば、一日分の行数が12行の日記の研究の場合は

$1$
$2$
$3$
$4$
$5$
$6$
$7$
$8$
$9$
$10$
$11$
$12$

のようにあらかじめSMART-GSの外のテキストファイルや、ユーザノートなどに書いておいて、それをコピー&ペーストして行番号を入力すると簡単です。

テキスト(Note)を開く

Images に付随するIDATを開くには、Workbench 右下の該当するタブを開きます。

Note(ユーザーズノート)を開く場合は、TextTreeのファイルのアイコンをダブルクリックしてください。 テキストの作成、編集については、テキストの作成、及び編集を参考にしてください。

IDATの名前変更

三つのタブ、つまり、三つのIDATの名前は Preference の IDAT Names という項目で自由に決められることになっています。また、それぞれのスプレッドでIDATの名前をマウスカーソルで選んで、そのIDATだけ名前を変えてしまうことも可能です。もし、Preference に指定された名前に戻したければ、入力した名前を空文字列にすれれば、Preference で指定してある名前にもどります。また、Preference で名前を指定してないと、つまり、空列を名前として入力してあると、強制的に Note1, Note2, Note3 という名称が設定されます。

イメージの切り替え

イメージは上述の通り、イメージツリーから開くことができますが、「Next Page」および、「Previous Page」のアイコンで切り替えることもできます。 「Next Page」には Alt + DOWN、「Previous Page」には Alt + UP のショートカットキーが割り当てられています。 また、内部的に、表示させたイメージの履歴は保存されており、「Move to next page in history」と「Move to previous page in history」のアイコンは、それぞれ履歴の次のイメージ、前のイメージを表示させます。 さらに、この履歴には、後述するイメージの拡大、縮小の縮尺も保存されていますので、この二つのアイコンで表示させた場合、以前の縮尺で表示されます。

イメージの拡大、縮尺

「Zoom in」「Zoom out」のアイコンで、イメージをそれぞれ拡大表示、縮小表示することができます。 さらに、「Full Size」のアイコンで元々のイメージのサイズで表示させることができます。 また、「Fit Width」でイメージの表示領域の横幅にあわせるように表示させ、「Fit Height」でイメージの表示領域の縦幅にあわせるように表示させることができます。 なお、内部的にこの縮尺は 25段階で管理されています。 「Fit Width」や「Fit Height」は「イメージの表示領域の横幅、および、縦幅に収まる最大の縮尺」で表示させるようにしていますので、ウィンドウのサイズによっては、横幅、縦幅とぴったりに表示されない場合もあります。

 

09 別ウィンドウでのエディタの起動(SMART-GS0.8も関連)

ワークベンチの左下の方にあるボタンEditor で、現在開いているスプレッドを別ウィンドウのエディタで開くことができます。これをエディタといいますが、エディタはワークベンチからイメージツリーやファイル操作のツールバー、メニューバーなどを取り除いたもので、同じスプレッドの複数の箇所を比較検討したいときなどに便利です。また、Compat Editor というボタンでは、イメージドキュメントも IDAT と同様のタブになった小さなエディタが起動されます。ディスプレィが小さい場合などには、こちらの方が便利なことがあります。コンパクトエディタは SMART-GS0.8にもあり、New Window というボタンで開くことができました。しかし、これは手違いでマニュアルでは説明されていませんでした。

エディタ、コンパクトエディタのボタンを押すと、ワークベンチで現在開いているスプレッドが開きますが、イメージツリーのイメージのアイコンを右クリックすると現れるメニューを使えば、ワークベンチで開いていないスプレッドを直接エディタやコンパクトエディタで開くこともできます。

 

Editor で起動されるエディタ

editor

Compact Editor で起動されるエディタ

compact editor

 

09 イメージドキュメントとテキストの表示位置

初期設定 の章の「SMART-GS 0.9での変更」という節で説明してあるように、Preference の Display Window Mode を変更すると、この動画のようにイメージとテキストの位置関係がリアルタイムに変更されます。 また、エディタにおけるイメージとテキストの位置関係は、そのエディタを起動したときの Preference の値で決まるようにしてあります。

イメージのマークアップ

SMART-GSでは、イメージにマークアップを行うことができます。 これにより、コンピュータ上のイメージに、普段紙の文書にマーカーで行うような操作が可能になります。 イメージにリンクを張る場合にはマークアップをする必要があります。

利用できるマークアップは以下の5種類あります。

どのマークアップを使うかはプルダウンメニューから選択します。Tool メニューから選択することもできます。ただし Anchor だけは異なる方法で使います。

09 SMART-GS 0.9 のメニューではテンポラリマークアップの項目が追加されています。

マークアップの右クリックメニュー

それぞれのマークアップをクリックすると選択された状態になります。マークアップが選択された状態で右クリックすると、以下のようなメニューが出てきます。

マークアップの種類によって出てくる項目は異なりますが、まず、それぞれのマークアップで共通して使うことができる項目について説明します。

Title:...
そのマークアップに付けられたタイトルを表示します。これを選択するとタイトルを変更できます。
Delete Markup
マークアップを削除します。
Set Link Source、Set Link Target、Show Local View
内部リンクを作成し、表示します。 リンクについて詳しくは後述します。
Protect Markup
マークアップを保護します。 保護すると削除や移動ができなくなります。
Release Protected Markup
マークアップの保護を解除します。
Resister in the dictionary
選択したマークアップを辞書に登録します。 辞書については、辞書機能の利用法で説明します。
Close-up
Rectanble と Polygon を選択している場合、そのマークアップの領域を別のウインドウで拡大して表示することができます。 拡大表示の別ウインドウでは、右クリックで拡大率を変更できます。

Select Next Rectangle など
同じ種類のマークアップの間で選択しているマークアップを切り替えることができます。
Add to Basket
これを選択するとさらに Resource Basket の一覧が表示されます。Resource Basket を選択すると、その Resource Basket にマークアップが保存されます。
Send to Basket List
Resource Basket の一覧を表示したウィンドウが開きます。その中から Resource Basket を選択すると、選択された Resource Basket にマークアップが保存されます。

091 0.9.1では、マークアップの選択された状態の表示が変わりました。各マークアップの選択された状態の表示は以下の通りです。

マークアップの種類通常の状態選択された状態
Rectangle
Polygon
Marker
MemoPad
Bookmark
Anchor

Rectangle

マウスカーソルをドラッグすることにより、長方形を描くことができます。 描いた Rectangle は、Preference の Region -- Movability が Movable になっている場合、ドラッグで移動させることができます。これはPolygon、Markerについても同様です。MemoPad と Bookmark に関しては最初から移動できるようになっています。

Marker

Marker では、マウスカーソルをドラッグすることにより、特定の幅の線を引くことができます。 右クリックメニューの Color で色を、Breadth で幅を指定することができます。Preference でデフォルトの色、幅を変更することもできます。

Polygon

Polygon では、多角形を描くことができます。 クリックで多角形の頂点を指定していき、ダブルクリックで多角形の描画が終了します。

MemoPad

MemoPad では付箋のように、イメージ上にメモを書くことができます。

右下隅の黒い三角形をドラッグすることにより、MemoPad のサイズを変更できます。 ダブルクリックすると、テキストを入力するダイアログが表示されます。右クリックメニューから「Add Text」を選んでテキストを入力することも出来ます。 MemoPad はドラッグすることにより、自由に場所を移動することができます。

また、MemoPad では、付箋から伸びる矢印を描くことができます。 右クリックのメニューから「Draw Arrow」を選んでから、イメージの任意の場所をクリックすると、MemoPad からの矢印を描くことができます。 さらに、MemoPad を選択してから、矢印の先をドラッグすると、矢印を移動させることができます。矢印を削除したいときは右クリックメニューの「Delete Arrow」を選択してから、削除したい矢印の先端をクリックして下さい。

Marker と同様に MemoPad も色を変更することが出来ます。また MemoPad はそれぞれの色で半透明にすることもできます。Preference メニューでデフォルトの色を変更することができます。

091Memopadの文字サイズを変更することできます。Memopadを選択して右クリックすると[Font Size]というメニューが現れる。それを選択するとサイズを入力するダイアログがあらわれるので10から30の整数を入力する(デフォールトは15)。

     

Bookmark

Bookmark では、イメージの任意の場所に目印となるピンを置き、その場所を記録し、自由に移動できるようにすることができます。

Bookmark のモードでイメージ上の任意の場所をクリックすると、Bookmark の名前を入力するダイアログが表示されます。 名前を入力すると、イメージ上にピンが表示されます。 これが、記録された Bookmark の場所です。 ドラッグすると位置を変更することができます。

記録した Bookmark への移動は、メニューの[Tool] -- [Bookmark] から行います。 [List] を選択すると Bookmark の一覧が表示されます。 Bookmarkの名前をクリックすると[Jump]と[Open]という選択肢が現れます。

Jump を選ぶとメインのウィンドウがそのブックマークの場所に切り替わります。Open の場合は新しいウィンドウでそのブックマークの場所が表示されます。

091 Bookmarkの色が選べるようになりました。右クリックメニューの[Color]からRed、Purple、Blue、Green、Greyの五色が選べます。これにともない、以前は選択されたBookmarkは赤で表わしていましたが、0.9.1では、選択されても色は変わらず、矢印で表わすようにしました。

Anchor

Anchor は IDAT 中のテキストとイメージ上の位置を関連付けるためのマークアップで、他のマークアップと異なる方法で使います。まず IDAT の中のテキストを選択して、メニューバーの「Mark up」ボタンをクリックします。するとマークアップの種類を訪ねるダイアログが現れるので、「anchor」を選択します。

次にそのテキストと関連付けたいイメージ上の位置をクリックするとその位置に Anchor が貼りつけられます。

作成された Anchor を選択して、右クリックメニューから「Jump to Linked Text」を選択すると、エディターの画面がその Anchor と関連付けられたテキストに移動します。また Anchor と関連付けられたテキストを右クリックして「Jump to Linked Paragraph」を選択するとイメージが Anchor の付けられた位置に移動します。

Resource Basket

Resource Basket は任意のマークアップをグループ化して保存し、マークアップが付けられている箇所をすぐ参照できるようにする機能です。

)URIはSMART-GSのリソース(スプレッド、テキスト、マークアップ、リンク等)を識別するために付けられたIDです。 URIが付けられているリソース、そしてその文法についてはSMART-GSを配布しているSourceForge.jpにある、SMART-GS開発のページの Wiki を参照してください。

09 テンポラリなマークアップ

SMART-GS 0.9 ではレクトアングル、ポリゴン、マーカ、ブックマークの4種類のマークアップはテンポラリにすることができます。マークアップは他人と議論をするときや、講演や講義で画像ドキュメントの特定の場所を示す際に使うことができます。たとえば、問題となっている数行をレクトアングルで囲んでみせるなどの使い方です。これは一時的に画像につける印と言えます。しかし、画像の恒久的マークアップを目的として作られたSMART-GS0.8のマークアップは、そのままにしておくと、SMART-GS を終了しても、マークアップが保存されてしまい、使い込むうちに段々と画像にゴミのマークアップが貯まっていました。これを防ぐには、使ったマークアップをこまめに消す必要がありました。

テンポラリなマークアップをこの面倒を避けるために導入された機能です。マークアップをテンポラリにしておくと、終了するときに、そのマークアップは自動的に削除されます。またテンポラリなマークアップは、シフトを押しながら右クリックするだけで消すこともできます。

テンポラリなマークアップは、場所を示すための便宜的なものなのでコネクション(リンク)は張れないようになっています。

テンポラリなマークアップを作るには、右クリックではなく、シフト+右クリックでメニューを開きます。テンポラリなマークアップには、雪の結晶のアイコンが付き、それがテンポラリ(溶けて消える)であることがわかるようになっています。テンポラリなマークアップは、マークアップを作るためにメニューバーなどから選択して作ることもできます。これらのメニューでは、テンポラリであることは tmp と表示されています。例えばテンポラリなレクトアングルは tmp Rectangle と表示されています。

テンポラリなブックマークとレクトアングル

tmp markups

 

09マウスカーソルのアイコン

バージョン0.8.1から各マークアップのツールに対応してマウスカーソルのアイコンが変わるようになりました。0.9ではEraserのアイコンにカーソルが指している位置(ホットスポット)を示すようにしました。下図の黄色い丸がホットスポットです。

Rectangle, Polygon Marker Memopad Bookmark Anchor Eraser

イメージとフォルダの追加、削除

イメージの追加や削除はイメージツリーからGUIを使って行ないます。

以下ではイメージの追加を「画像をインポートする」ということにします。

例えばフォルダfolder1に画像をインポートしたいときは、このフォルダクリックして選択状態にし、

次にそのフォルダの上で右クリックして右クリックメニューの Import Images を選びます。

ファイル選択のウィンドウが現れますので、画像ファイルを選び、OKを押します。

上の図では、LectureNotesS09_ver2 というフォルダにある多数の jpg ファイルの内、S09_008 という名称のファイル選んでいます。SMART-GSで使用可能な画像ファイルの形式(タイプ)は、バージョンにより変わりますが、使っているSMART-GSで使える画像形式は、上の図の jpg,BMP,bmp,...,gif のように「ファイルタイプ:」として表示されますので、その範囲で選んでください。ファイル選択のウィンドウは、通常では「ファイルタイプ:」に示された形式の画像の一覧しか表示しませんから、その範囲で選べば問題ありません。

ただし、テキストフィールド「ファイルタイプ:」の右のボタンを押すと、別の表示の仕方を選択できるようになっていて、「すべてのファイル」という表示法を選ぶと、フォルダLectureNotesS09_ver2 の中にあるすべてのファイルとフォルダが表示されます。この場合は、使っているSMART-GSがサポートしてない形式のファイルも見えてしまいますが、サポートされていない画像ファイルを選んでもインポートはできません。

また、すでに同じ名前の画像ファイルが登録されている場合や、SMART-GSのファイル名、ディレクトリ名の規則に合わないものも、同様にインポートできません。

フォルダの追加

先ほどの例では folder1 にイメージを追加しましたが、フォルダを追加することもできます。イメージの追加の時と同様に、folder1を選択した後、右クリックして、今度はメニューから Make New Directory を選択します。そうすると新規フォルダの名称を聞いてきますので、入力するとその名称でフォルダが作成されます。

イメージ、フォルダの名前として使える文字列

イメージツリーのイメージとフォルダの名前には、使えない文字やパターンがあります。たとえば、"フォルダ1"という名前は使えませんが、"フォルダ1"は使えます。この二つの違いは、前者の1が全角で、後者の1が半角であることです。これは2011年10月9日現在のSMART-GSのイメージ名、フォルダ名の文法が、次のように定められているからです:

  1. 使える文字は次のいずれかのみ:
  2. 1文字以上の長さを持つ文字列でなければいけない。
  3. 空白文字(Space, Tab)だけからなる文字列は名前には使えない。
  4. 先頭の文字が次の3つの半角文字のいずれかであってはいけない: .@#
  5. 文字列 dsc は使えない。また、この文字列の三つの文字の幾つかを大文字にしたものは使えない。たとえば Dsc は使えない。

大変にややこしいルールですが、これは現在のイメージツリーがOSのファイルシステムの一部を見るためのビューワかファイラの様な作りになっており、イメージツリーのイメージやフォルダの名前が、そのまま、OSのファイルやフォルダの名前になっているからです。しかも、同じイメージツリーを、Windows, Mac, Linux のすべてで同時に使えるようにするために、なるべく小さな範囲を選んであります。基本的には、Windows, Mac, Linux すべてに共通するファイル名として許容できるASCIIの文字列がファイル名であり、現在のユーザに日本史関連の人たちが多いことから、全角の漢字と仮名を追加したものが、この文法なのです。その他の細かい条件は主にSMART-GSのシステムの都合からきています。ただし、3は混乱を防ぐための措置です。

イメージとフォルダの削除

イメージの削除は、イメージを選択して、右クリックメニューから Delete Image を選びます。ディレクトトリは同様に Delete Selected Directory で削除します。また、イメージやフォルダを複数選んだ場合には Delete Selected Items で削除します。イメージとフィルダを同時に選んで削除することも可能です。

これらの削除の操作をすると、必ず次の様なダイアログが表示されます。

後で説明する gsx ファイルを一つしか持たない間は、どちらを選んでも大きな違いはありません。サンプルの gsx ファイルに読み書きしている間の初心者は delete the items を選んでください。しかし、gsx ファイルを二つ以上作るようになったら必ず次の「画像フォルダとインポート・削除の仕組み」を読んで、 delete the items を選ぶか don't delete the items を選ぶかを目的に応じて選ぶようにしてください。

画像フォルダとインポート・削除の仕組みadvanced (この節は自分で新しいgsxファイルを作るようになるまでは読む必要はありません)

ここでちょっと複雑な話をしなくてはなりません。それはイメージツリーとOSのファイルとフォルダのツリーの関係についてです。といっても、それほど複雑ではあるわけではありませんから、SMART-GSの操作に慣れたら、必ず、これを理解してください。

SMART-GSには画像フォルダというOSのフォルダ(ディレクトリ)が一つ決まっています。これは「インストール、起動、設定」の章の「ユーザ設定:画像フォルダの設定を例にして」の画像フォルダです。SMART-GSの画像は、すべてこのフォルダ以下におかれます。イメージツリーの root は、このフォルダを意味しています。つまり、画像フォルダのパスが Z:/foo/goo/hoo/ ならば、イメージツリーの root, root/folder1/ と言うフォルダは、それぞれ、Z:/foo/goo/hoo/, Z:/foo/goo/hoo/folder1/ というOSのフォルダを表しており、パス root/folder/S09_008 の画像は、 Z:/foo/goo/hoo/folder1/ にあるファイル名が S09_008 の画像ファイル、たとえば、 Z:/foo/goo/hoo/folder1/S09_008.jpg や Z:/foo/goo/hoo/folder1/S09_008.gif のことなのです。

画像ファイルS09_008.jpgをイメージフォルダのフォルダroot/folder1/ にインポートをするとは、この画像をZ:/foo/goo/hoo/folder1/にコピーして、S09_008 という名前でイメージツリーに登録することを意味しています。

また、folder1 の下に、新規フォルダ folder2 をつくるということは、Z:/foo/goo/hoo/folder1/folder2/ という新規フォルダをOS上で作り、それをイメージツリーにパス root/folder1/folder2 のフォルダとして登録することなのです。

この様にイメージツリー上のフォルダやイメージの追加は、実際のOSのフォルダやファイルを新たに作り出します。ですから、それらをイメージツリーから削除する場合には、

  1. イメージツリー上のイメージやフォルダを削除すると同時に実際の画像ファイルやフォルダも削除する。
  2. イメージツリー上のイメージやフォルダを削除するが、実際の画像ファイルやフォルダも削除しないで残しておく。

という二つの選択肢があるのです。削除を行なうときに聞かれる、 delete the items と don't delete the items はこの選択肢を選ぶものなのです。

後者を選ぶケースには、一つの画像フォルダに対して複数のイメージツリーを作る場合が考えられます。イメージツリー T1 を操作しているとき、その root/folder1/S09_008 を delete the items で消しますと、その対応するイメージファイルも消えますので、別のイメージツリーT2 に root/folder1/S09_008 が登録されていたら、T2 を使って作業するときに画像ファイルがなくて表示することができなくなってしまいます。こういうときには、 don't delete the itemsで消して、画像ファイルをキープするようにするのです。SMART-GS では、イメージツリーは一度に一つしか操作できませんから、こういう問題がおきるのは、T1を操作して保存し、次に保存していたT2を読み出して使うときのみということなります(ただし、一度に二つのSMART-GSを起動すると、gsxファイルが一つでも同じ問題が起きてしまいます。SMART-GSを二つ以上同時に起動すると、この他にも色々と問題がおきますから、あまりお勧めできません。)。イメージツリーは後で出てくる gsx ファイルに保存されるので、こういう状況が起きるのは複数の gsx ファイルを使うときだけということになるのです。ですから、一つのgsxファイルしか使わないという人は、この問題はあまり気にしなくてもよいのです。

イメージツリーは以上のようにして作成されますので、「イメージツリーは、OS上の画像フォルダより下のファイルとフォルダのなすツリーの、部分ツリーになる」という性質があります。つまり、イメージツリーは、画像フォルダのツリーから、幾つかの画像ファイルや、フォルダ(と、その下のフォルダとファイルのすべて)を「隠した」して出来ているのです。

この画像フォルダの「隠された部分」をツリーに登録する機能もあります。それがフォルダを右クリックしたときに現れるメニューの Image Folder Operations: です。この項目には、さらに二つサブメニュー項目があり、それにより隠れている画像ファイルやフォルダ(とその下あるもののすべて)をイメージツリーに一挙に登録することが可能です。

すでに大量の資料を階層状に分類して持っている場合、たとえば、1899年から1910年までの資料を月ごとに 1899/01, 1899/02/,...,1910/11/,1910/12 という24個のフォルダに分類して持っている場合、先に説明した当たらしいフォルダを作る方式では全部で26回もイメージツリーのフォルダを作る必要がありますし、画像が数がおおければ、そのコピーも大変です。そういうとき、OSのコピーの機能を使って画像フォルダに、1899 と 1910 というフォルダをコピーしておけば、 Image Folder Operations: の Add Directory and Ancestors to Image Tree でこの二つのフォルダをイメージツリーに一度に登録することが可能です。

ただし、この方法で登録する場合には、イメージやフォルダの名前が SMART-GSの名前の文法にあっているかチェックされないので注意してください。実は、古いバージョンのSMART-GSは Windows 専用に作られており、その頃には、イメージやフォルダの登録は、「OSのフォルダから一気に読む」方式で行なわれていました。しかし、現在のバージョンでは、Windows, Linux, Mac の三つのOSを同時に使えることを保障するためや、その他の理由で、ファイル名やフォルダ名に厳しいチェックがかかるようになりました。そのために、この方式での登録は二次的なものになったのです。そのため、昔からのユーザで、一つのOSしか使わないが、もっと自由なファイル名・フォルダ名を使いたいという人のために、この以前の方法を、そのまま使ってイメージやフォルダを登録することができるようにしたのが、Image Folder Operations なのです。そのために古いやり方をそのまま踏襲してイメージファイルの名前などはチェックしないようになっているのです。

テキストの作成、及び編集

今までイメージについて詳しく見ましたが、今度はテキストです。テキストの操作は、イメージと違い、基本的にはよく知られたものです。

テキストの作成

ユーザーが作成するテキストは、ユーザーズ・ノートに限定されます。その他のテキストは、例えば、 IDATの場合、Image Documentに付随して存在するので、新たに作成する必要はありません。 では、どうやってユーザーズ・ノートが作られ編集され削除されるかを説明しましょう。

まず、新規のNoteを作成します。画面左のウィンドウのタブ「Notes」をクリックします。

次に、TextTree内のディレクトリのアイコン(最初はrootだけがあります)を選択して右クリックすると、以下のポップアップメニューが表示さ�ます。

「Make New Text」を選択すると、「Input Note Name」と表示されたダイアログが現れます。テキストの名前を入力後、「了解」を選択してください。例えば「sample」という名前を入力すると、下の画面のように、「sample」というNoteが作成されます。

作成したテキストのアイコンをダブルクリックすると、下のような画面が表示され、テキストの編集ができます。

なお作成したテキストを選択し、右クリックすると、「Change Name」、「Delete Selected Note」というポップアップメニューが表示され、選択されたテキストの名前の変更、選択されたテキストの削除ができます。

Images と同様に、Notes でも新しいディレクトリを作成したり、順番を変更したりできます。

テキストの編集

テキストの編集については、Noteの場合もそれ以外のText Document(IDAT、Explanatory Note)の場合も同様の操作ですので、Noteの場合を取り上げて説明します。

ボタンについては図を参照してください。

テキストの表示モード

テキストの表示モードには、下記の三種類があります。

Browseモード
テキストをブラウズできます。編集はできません。

Wysiwygモード
テキストをWysiwyg(What you see is what you get)モードで編集できます。

Sourceモード
テキストがXMLのソースで表示されます。 ここで編集することもできます。しかし、編集は SMART-GSの仕組みに精通していないと、正しく使うことはできず、色々な機能を壊してしまう可能性さえあるので、SMART-GSの仕組みを知らないひとは見るだけで極力触らないようにしてください。

各モードの切り替えは、ツールバーのBrouse、Edit、Sourceボタンで行います。

カット、コピー、ペースト

カット、コピー、ペーストはツールバーのボタンを使用するか、イメージを選択して右クリックで表示されたメニューから行えます。 また、これらの操作はショートカットキーを利用しても行うことができます。 カットはCtrl + X 、コピーはCtrl + C 、ペーストはCtrl + V になっています。 ペーストについては、右クリックで表示される「Paste as Text」を用いると、タグなどを含めないテキストの部分だけをペーストできます。

書式の編集など

書式の編集などは下図のツールバーで行います。

検索について

上の図の検索ボタンを押すと、下図のように現在のテキストについて(図の場合は「sample」と名付けられたNote内のテキストについて)インクリメンタルサーチを行うことができます。

特殊文字の入力について

上の図で「特殊文字の入力」と説明されたボタンを押すと、下のような画面が表示されます。

この文字の一覧から入力したい文字を左クリックすると、その文字が入力できます。 人名や地名など、普通は使わない文字を入力するときに便利です。

通常の入力はキーボードから行ってください。

テキストのマークアップ

HTMLの文書と同様に SMART-GS のテキストもマークアップすることが可能です。マークアップはHTMLのアンカーと同様に、そこから、あるいは、そこへのリンクを可能にしますし、単なる強調表示などのためにだけ使われることもります。

source ボタンを押すと、テキストのソースを閲覧したり編集できますが、その実際はほぼHTMLであることがわかります(ちなみに、ソースは極力直接編集しないでください。直接編集した場合は動作が保証できません)。しかし、マークアップの方法などはHTMLとはちがいます。HTMLではページ内部のテキストの一部分にリンクをしようとするとアンカーを使うことになり、その名前を自分で考える必要があります。とろが画像のマークアップでは、レクトアングルなどのマークにユーザが名前をつけることはありませんでした。これはSMART-GSではリソースの名前はシステムが管理しているからです。テキストの場合も同様でマークアップには、すべて内部でシステムが通し番号をつけて、それを利用してリンクなどを行ないます。

マークアップをするには、まず、マークアップしたいテキストの一部を選択します。そして、その後、右クリックで表示されるボップアップメニューから「Mark up」を選択します。そうすると次の様なマークアップ用ダイアローグが表示されます。(ボップアップメニューのかわりにツールバーの「Mark up」ボタンを使うこともできます。)

このダイアローグでマークアップに使うタグの種類を選択して、OKを押せばマークアップが完了します。タグは新規作成、及び削除ができます。 あらかじめ用意されてあるタグは、以下の五種類です。

上図で reference と表示されているメニューを右の▼ボタンを押してプルダウンすると、これら全部のタグのリストが表示されます。 また、reference を newtag と書き換えて適用すると、選択した部分にタグ newtag でマークアップされると同時に、newtag が新しいタグとしてこのリストに追加されます。 tags.txt ファイルに書き込むことによって新しいタグを追加することができます。 タグをリストから消すには、それを選択し、右の delete ボタンを押します。

タグを選択後、「了解」を選択すると、マークアップが完了します。 マークアップされた箇所は、各タグごとに強調されて表示されます。

タグの表示の仕方を変えたい場合は、起動フォルダーにある css.txt というファイルを編集してください。 css.txtでは、例えばreferenceの場合、

  #reference{
    
  color:red;
    
  font-size:20pt;
  }
    

のように書かれています。 この部分のcolorやfont-sizeなどを変更することで、referenceタグのついたマークアップされた部分の表示を変えることができます。 これは css を真似てありますが、css の極一部の機能にしか対応していませんので、css.tx に最初からある機能の範囲(色、サイズなど)で変更を行なってください。

マークアップの削除

マークアップを削除するには、マークアップ内にマウスカーソルを移動し、右クリックで表示されるポップアップメニューの Remove Mark up 項目を選びます。あるマークアップが削除されると、そのマークアップがリンクの一端になっているリンクは、すべて削除されます。

リンクの作成、表示

WWWでは、HTMLというマークアップ言語を使って、テキストをマークアップします。今説明したばかりのテキストのマークアップは、これと同じものです。SMART-GSではテキストのマークアップに加えて、イメージにもレクトアングルなどで様々なマークアップが可能でしたし、それが簡単にできるようになっています。これは史料研究用に開発されたSMART-GSの大きな特徴の一つです。実はHTMLやPDFでも、SMART-GSの画像マークアップに似た機能は存在するのですが、実際に使ってみると大変使いづらく、史料のコピーにコメントをペンで書き込んだり、メモを貼ったり、するようには簡単にできません。そのため史料研究中の思考の流れが、HTMLやPDFの操作のために分断されてしまいます。これは研究者にとっては大きなマイナスです。なぜそうなっているかというと、HTMLやPDFが「出版」つまり、公開用に作られているからです。これら既存のツールは研究が完成した後に、それを綺麗な形にして公開するためには大変適しています。しかし、研究最中のメモ用ツールとしては不適当なのです。

ITの時代になっても、紙媒体というものは大変便利なもので、書き込みやマークアップに関して言えば、いまだにSMART-GSより、紙媒体の方が軽快性、敏捷性、自由性については優れているように思います。しかし、紙媒体には、一度書いたマークアップの削除ができないという編集の困難性、物理的な媒体なので大量に持ち運べない、という物理的制約、翻刻・メモ・論文原稿などの研究者が作成するテキストが電子媒体上にあり、それらはディスプレイ上に表示されキーボードを使って入力されるが、史料が紙媒体上にあると、研究作業が二種類の大きくことなった媒体を必要とするという媒体の不斉一性、などの問題があります。最後の「媒体の不斉一性」は分かりにくいかもしれませんが、具体例で言えば、視線が机の上の紙とディスプレイとの間を往復する、手がキーボード・マウスとペン・ポストイットなどの間を往復する、などの問題を引き起こします。これは作業を何時間も続けて行う研究者にとっては大きなストレスを引き起こしますが、SMART-GSを使えば一貫して画面とマウス・キーボードだけの作業で済むためにストレスが大変軽減されるということがユーザから報告されています。またマイクロフィルムを焼いたモノクロの史料コピーに比べ、カラー高精度の電子画像はクローズアップすればあたかも実物をルーペで見ているかの様に細部まで観察できるという、特に焼けやシミなどが激しい史料の研究の際には大きな差を生む利点があります。 おそらく、これらの利点から、百枚程度以上の史料を使う研究では、総合的にみれば、画像史料、特に高精度カラー画像、とSMART-GSの組み合わせによる方が、紙史料を使うより軽快・快適に研究を進められるはずですし、その差は史料数が膨大になればなるほど発揮されることになります。

しかし、SMART-GSが紙媒体に比べて持つ最も大きい優位性のひとつは、画像、テキストの違いを超えてマークアップ間にリンクを張ることが可能だということでしょう(このほかに、画像のままでサーチができるという大きな特徴もあります。これについてはイメージサーチ/テキストサーチの使用法の章で説明します)。 これはWWWで多数の文書がリンクで関係づけられているのと同じ機能です。しかし、WWW、つまり、HTMLの範囲では、画像にリンクを張ることは簡単でも、画像の一部、たとえば、画像中のある部分をレクトアングルで指示し、それにリンクを張ることは、HTMLテキストのマークアップの間にリンクを張ることに比較してさえ大変面倒なのです。SMART-GSは、これが比較にならないほど簡単にできるように設計されています。

また、SMART-GSのリンクは双方向かつ1対多対応になっています。双方向性とは、リンクの終端からリンク元を知ることができて、そこにジャンプできることを意味しています。これは自分にリンクをかけているものすべてを瞬時にリストアップすることもできます。また、リンクの1対多対応とは一つのソースが多数のリンクを持つことができることを意味しています。たとえば人名索引の項目から、その項目の出現すべてリンクを張ることができます。また、リンクに、そのリンクの意味を説明した説明のメモ(Explanatory Note)をつけることができて、どうしてリンクを書いたのかを記録しておくことができます。また、リンクの作成者とリンクの作成日時が自動的に記録されますので、特に複数の人が協働して仕事をするときなどに便利です。

この様にHTMLのリンクとは大きく異なるため、SMART-GSのリンクは正式には Connection と呼ばれます。しかし、通常は大変広く普及しているHTMLの呼び名に合わせてリンクと呼んでいます。

また、このSMART-GS独自のリンクの他にテキストの外のHTMLのリソース、特にWEBページなどを参照するために、通常の意味のHTMLのリンクであるExternal Link というものもあります。 External Link はテキストのマークアップにだけつけることができます。

以下ではこのリンクの使い方を説明します。

リンクの作成

リンクはイメージのマークアップやテキストのマークアップの間に張ります。まずリンクのどちらかの端となるマークアップを選択し、右クリックします。

表示されたプルダウンメニューから、「Set Link Source」(または「Set Link Target」)を選択します。 すると、画面の下部にそのマークアップのURIが「Source: URI」(または「Target: URI」)という形式で表示されます。

次に、別のマークアップを選択し、右クリックします。 表示されたプルダウンメニューから、「Set Link Target」(または「Set Link Source」)を選択します。

下のような画面が表示されますので、リンクの名前(Connection Name)はユーザが自由に決めることができますが、リンクができると自動的にデフォルトの名前「ユーザ名@作成した年月日時間」が生成されて Connection Name のフィールドに置かれていますので、必要に応じて、これを編集してください。リンクに説明を付ける必要があれば「Explanatory Note」ボタンを押してExplanatoryNoteを書きます。

「OK」を選択すれば、リンクの作成が完了します。なお、この画面で「Cancel」を押してもリンクは既に作成されていますが、この場合はリンク名などの編集内容は保存されません。また、今の例ではソースを先に選らび、後でターゲットを選びましたが、ターゲットを先に選んで、後でソースを選んでも構いません。

 

リンクの表示

リンクを作成したマークアップを選択し、右クリックします。 リンクを作成していなかったときは選択できなかった「Show Local View」が選択できるようになっているので、選択します。

下のようなLocal View ウィンドウが開きます。 画面左の画像は選択したマークアップとリンクしているマークアップの画像です。この画像をクリックするとそのマークアップを含むイメージが別なウィンドウで表示されます。 また、リンクの名前とExplanatoryNoteの編集もここから出来ます。

選択したマークアップが複数のマークアップとリンクしているときには、それらのマークアップすべてがLocal Viewウィンドウに表示されます。

URIの左の部分は、選択されたマークアップから見てこのマークアップがソース側なのか、それともターゲット側なのかを表します。 例えば、あるマークアップ(Aとします)をソース、別のマークアップ(Bとします)をターゲットとしてリンクを作成した場合、BのLocal Viewを表示したときには、Aはソース側になります。 (ソースとターゲットの詳細についてはReasoning Webの章で解説します。)

画像の右上に表示されているのは、このリンクの名前で、作成したユーザの名前(@マークの前)と、それを作成した日時(@マークの後)からできています。ただし、これはシステムが作ってくれるデフォールト値であり、ユーザは、これを自由に変えることができます。ちなみに、上のリンクが三つ表示されている例でいいますと、一番上のリンクは、ユーザによりエディットされていないならば、User というユーザが、2011年9月27日3時59分19秒に、このリンクを作成したことが記録されていることになります。三番目のリンクの時間が、こういう読み方では説明できないものになっていますが、これは所謂 Unix 時間です。古いversionで、時間の表現として所謂 Unix 時間が使われていたためにこのような表現になっています。

また、右下の Explanatory Note という領域は、全体が大きなボタンになっていて、これを押すとメモを書くための簡単なエディタが起動されます。

リンク先のターゲットやソースの詳しい情報を見たいときには、その画像の上にマウスを移動させると次の図のような詳細情報が表示されます。

複数あるリンク先の中から、自分が意図したものを選ぶには、まず第一に表示された画像によりどのマークアップか認識しますが、同じようなマークアップが多数あるときなどには、上の図の情報を参照すれば、殆どの場合に識別が可能でしょう。しかし、それでも無理なときは、リンクの名前から区別することが可能です。もし、デフォルトの値で、それが判別し難い場合は、ユーザは積極的に、リンク名(コネクション名)を変更して、それにより複数のリンクが互いに区別できるようにすべきです。それでも識別困難なときは画像を右又は左クリックしてリンク先を表示して判別します。

画像消失

何かの誤りでスプレッドの画像ファイルが削除されてもスプレッドは残ります。この場合を画像消失と言います。この状態で、リンクの表示を行なうと次の図の3番目のように表示されます。画像消失の場合は画像を再度見つけて来て、該当する場所に戻せば元に戻ります。

リンクの削除

作ったリンクを削除したいときには、Reasoning Web の Link View を使って削除します。これについてはReasoning Web の章、リンクの除去と情報表示を参照してください。また、リンクのソースかターゲットが削除されたときも、リンクは自動的に削除されます。WWWで使われているHTMLでは、リンクは切れても「リンク切れ」状態になるだけで、リンク自身は残るとも考えられます。しかし、SMART-GS0.8では、直ぐにリンクも削除されます。しかし、近い将来、これは変更されることが予定されています。

External Link

テキストのマークアップ上で右クリックすると、イメージの場合のメニューにはない Set External Link というリンクがあらわれます。これを選択すると HTML のURLを入力するためのダイアログが開きます。これに適当な URL を入れると、それ以後、そのマークアップをクリックすると Preference の Web Browser でそのパスを指定したブラウザーが立ち上がり、指定した URL のページが表示されます。リンクを削除したいときには右クリックして「Remove External Link」を選んでください。

GSXファイルの保存、読み込み

今まで解説した、マークアップやテキスト、そしてリンクなどの情報は、GSXファイルに保存されます。 GSXファイルに保存しなければ、それまで行った作業は保存されません。 イメージの絶対パスを同じにしておけば、GSXファイルは共有できます。 これについては、近くsmart_gsフォルダによる相対パスに対応させる予定です。

GSXファイルの保存、読み込みは、画面上部のアイコンか、メニューの [File] -- [Open]、および、[Save] で行います。

左が読み込み、右が保存です。どちらかを選択すると、次のような画面が表示されます。

GSXファイルを保存する場合は、保存するファイル名を入力します。既存のファイルに上書きする場合はウィンドウからファイルを選択して下さい。 ファイルタイプを「gsx」にしておけば、保存されたファイルには自動的に拡張子「.gsx」が付きます。

GSXファイルを開く場合は、開きたいファイルをマウスでクリックするか、ファイル名を入力します。

なお、GSX ファイルを開いて編集すると、同じ場所に拡張子が .gsx.bak となるバックアップファイルが作成されます。 また、作業中の自動保存ファイルとして、拡張子が .auto となるファイルが 10分毎に保存されます。

WebDAVによるGSXファイルの保存、読み込み

また、WebDAVを利用することで、GSXファイルをサーバ上に保存することが可能です。 WebDAVを利用しての GSXファイルの保存、読み込みには、[Open GS File] と [Save GS File] のアイコンの右のアイコンか、[File] -- [Open from WebDAV]、および、[Save to WebDAV] で行います。

WebDAV用の保存、読み込みボタンを押すと、あらかじめ設定(注1)されているサーバ上のファイル一覧が表示されます。 保存するならば、ファイル名を指定してSAVEボタンを押してください。 読み込むならば、一覧から読み込みたいファイルをクリックして、OPENボタンを押してください。

WebDAV利用時の注意点として「編集の衝突」があります。複数の人が同じ GSXファイルを同時に編集し始めると混乱が生じることがあります。 例えばAさんがtest.gsx をサーバから読み込むで編集している間に、Bさんが test.gsx を変更したとします。 それを知らずAさんが test.gsx を変更すると、Bさんの変更は失われてしまいます(注2)。 このような問題を完全に解決する方法はありません。 しかし、「編集の衝突回避」の仕組みは、SMART-GS を共同作業用のツールにするために是非必要な機能です。

この問題は Wikipedia などの Wiki システムでも同じ問題が起きることが知られており、Wikipedia ではユーザーが編集結果を保存しようとすると、テキストの変更の差分を表示して、意図どおりの変更になっているかどうかチェックを促します。 比較的希にしか変更が起きず、しかも、ファイル構造が簡単なため Wikipedia では、これにより大きな問題は起きなくなっているようですが、SMART-GS のデータの構造は、Wiki より遥かに複雑なので差分を表示するのが困難です。 また、大規模な史料を共同で翻刻する場合などでは、未完成の原稿を共有するために、Wikipedia に比べて、遥かに頻繁に変更と衝突が起きるものと考えられます。 そのため、「編集の衝突」の問題は、今後、解決すべき大きな問題であり、gsx ファイルと文献研究での共同作業という、特殊性を考慮した新たな方法を作ることを検討しおり、そのために実際の人文学の研究教育の現場(京大文学部・文学研究科における現代史、思想史などの演習・講義)で SMART-GS を使用し、必要な条件を割り出すことを予定しています。

現在のSMART-GSには、この使用実験を行うために「手動でファイルをロック/アンロックする機能」が用意されています。 この機能は実験用なので不完全ですが、多くの場合には、これを使うだけでも問題を大幅に軽減できると思われます。 この lock/unlock の仕組みと、その使い方の例を以下で説明します。

WebDAV上のファイルをロックするには、そのファイルを選びロックボタンを押します。 ロックされたファイルは、アンロックされるまで上書きすることができません。 アンロックにはアンロック・ボタンを使います。 ロック・アンロックの状態に関わらず、読み込み(open)は自由にできます。

この機能を使えば、先ほどの例では、以下のような手順を経れば、Aさんは test.gsx の編集中に、B さんのような他人が test.gsx に書き込んでしまうことを防げます。

  1. Aさんが test.gsx をロックする。
  2. Aさんが test.gsx をopen して、そして、test.gsx に変更を加える。
  3. Aさんが test.gsx をアンロックし、test.gsx を保存。

厳密に言えば、3 のアンロックの後で、Aさんが test.gsx を保存する前に B さんが test.gsx を変更してしまう可能性があります。 本当はAさんが test.gsx を保存した後で、unlock できるようにするべきなのですが、現在の SMART-GS/WebDAV ではこれはできないので、アンロックと保存の間を短くすることが重要です。 また、現在の SMART-GS/WebDAV では、誰でもアンロックできるようになっているので、人がロックしたものを勝手にアンロックする人がいれば、上の手順を経ても編集の衝突は回避できません。 ロックされたファイルは勝手にアンロックしないようにすることが大切です。 書き込みたいファイルがロックされているときには、アンロックされるまで待ち、アンロックされたら変更内容を確認した上で、自分の変更を保存するような工夫が必要です。

互いに良く知っている人たちのチームが使おうことを前提としている現在の SMART-GS の利用形態では、これらの問題が起きる可能性は極めて少なく、数分で行える変更の場合は上の手順で、少し時間がかかりそうな場合は、上の手順を少し変えた次の手順を使えば問題は発生しないと思われます。

  1. Aさんは test.gsx を入手して、また入手した時間を記録しておく。 そして、それを編集する。これには数日かけても構わない。
  2. 1で編集を終えたファイルを仮に test.gsx* と書く。 手元の test.gsx* を WebDAV 上の test.gsx に上書きするためには、まず、test.gsx を lock し、それの最終更新時間が1で記録しておいた入手時間より古ければ、そのまま unlock/save を行うが、もし、自分が入手した後に変更が起きていれば、現在のファイルの内容と test.gsx* の内容を比較し、それにより上書きするかどうか判断する。 必要があれば、変更をした人を見つけて、その人と相談をする。

初期設定 トップへ戻る イメージサーチ